Follow @Openwall on Twitter for new release announcements and other news
[<prev] [next>] [day] [month] [year] [list]
Date: Fri, 08 Sep 2017 11:20:23 +0000
From: Sean Owen <>
Subject: CVE-2017-12612 Unsafe deserialization in Apache Spark launcher API

Severity: Medium

Vendor: The Apache Software Foundation

Versions Affected:
Versions of Apache Spark from 1.6.0 until 2.1.1

In Apache Spark 1.6.0 until 2.1.1, the launcher API performs unsafe
deserialization of data received by  its socket. This makes applications
launched programmatically using the launcher API potentially
vulnerable to arbitrary code execution by an attacker with access to any
account on the local machine. It does not affect apps run by spark-submit or
spark-shell. The attacker would be able to execute code as the user that ran
the Spark application. Users are encouraged to update to version 2.2.0 or

Update to Apache Spark 2.2.0 or later.

Aditya Sharad, Semmle

Powered by blists - more mailing lists

Please check out the Open Source Software Security Wiki, which is counterpart to this mailing list.

Confused about mailing lists and their use? Read about mailing lists on Wikipedia and check out these guidelines on proper formatting of your messages.