![]() |
|
Message-ID: <df74c693-45fb-4c02-bc75-32f70633706a@web.de> Date: Sun, 9 Feb 2025 12:00:11 +0100 From: Markus Elfring <Markus.Elfring@....de> To: Ethan Carter Edwards <ethan@...ancedwards.com>, kernel-hardening@...ts.openwall.com, linux-hardening@...r.kernel.org, Ingo Molnar <mingo@...hat.com> Cc: LKML <linux-kernel@...r.kernel.org>, kernel-janitors@...r.kernel.org, Ben Segall <bsegall@...gle.com>, Peter Zijlstra <peterz@...radead.org> Subject: Re: [PATCH v2] sched/topology: change kzalloc to kcalloc > We are replacing any instances of kzalloc(size * count, ...) with > kcalloc(count, size, ...) due to risk of overflow [1]. * See also: https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/tree/Documentation/process/submitting-patches.rst?h=v6.13#n94 * How do you think about to use a summary phrase like “Replace two kzalloc() calls by kcalloc() in sched_init_numa()”? * Would you be looking for any coccicheck extensions accordingly? Regards, Markus
Powered by blists - more mailing lists
Confused about mailing lists and their use? Read about mailing lists on Wikipedia and check out these guidelines on proper formatting of your messages.