Follow @Openwall on Twitter for new release announcements and other news
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date: Fri, 2 Oct 2020 09:13:03 -0500
From: Josh Poimboeuf <>
To: Peter Zijlstra <>
Cc: Miroslav Benes <>,
	Sami Tolvanen <>,
	Masahiro Yamada <>,
	Will Deacon <>, Steven Rostedt <>,
	Greg Kroah-Hartman <>,
	"Paul E. McKenney" <>,
	Kees Cook <>,
	Nick Desaulniers <>,,,,,,,,,
Subject: Re: [PATCH v4 04/29] objtool: Add a pass for generating __mcount_loc

On Thu, Oct 01, 2020 at 03:36:12PM +0200, Peter Zijlstra wrote:
> On Thu, Oct 01, 2020 at 03:17:07PM +0200, Miroslav Benes wrote:
> > I also wonder about making 'mcount' command separate from 'check'. Similar 
> > to what is 'orc' now. But that could be done later.
> I'm not convinced more commands make sense. That only begets us the
> problem of having to run multiple commands.

Agreed, it gets hairy when we need to combine things.  I think "orc" as
a separate subcommand was a mistake.

We should change to something like

  objtool run [--check] [--orc] [--mcount]
  objtool dump [--orc] [--mcount]


Powered by blists - more mailing lists

Confused about mailing lists and their use? Read about mailing lists on Wikipedia and check out these guidelines on proper formatting of your messages.