|
Message-ID: <CAGXu5j+TzwCHpX6sGkQj4QDeZTR=MkGGaXawzAYbxCJQoT_9aQ@mail.gmail.com> Date: Mon, 27 Feb 2012 12:15:38 -0800 From: Kees Cook <keescook@...omium.org> To: Will Drewry <wad@...omium.org> Cc: Oleg Nesterov <oleg@...hat.com>, linux-kernel@...r.kernel.org, linux-arch@...r.kernel.org, linux-doc@...r.kernel.org, kernel-hardening@...ts.openwall.com, netdev@...r.kernel.org, x86@...nel.org, arnd@...db.de, davem@...emloft.net, hpa@...or.com, mingo@...hat.com, peterz@...radead.org, rdunlap@...otime.net, mcgrathr@...omium.org, tglx@...utronix.de, luto@....edu, eparis@...hat.com, serge.hallyn@...onical.com, djm@...drot.org, scarybeasts@...il.com, indan@....nu, pmoore@...hat.com, akpm@...ux-foundation.org, corbet@....net, eric.dumazet@...il.com, markus@...omium.org, coreyb@...ux.vnet.ibm.com Subject: Re: [PATCH v11 06/12] seccomp: add system call filtering using BPF On Mon, Feb 27, 2012 at 11:54 AM, Will Drewry <wad@...omium.org> wrote: > On Mon, Feb 27, 2012 at 11:09 AM, Oleg Nesterov <oleg@...hat.com> wrote: >> On 02/24, Will Drewry wrote: >>> +static struct seccomp_filter *get_seccomp_filter(struct seccomp_filter *orig) >>> +{ >>> + if (!orig) >>> + return NULL; >>> + /* Reference count is bounded by the number of total processes. */ >>> + atomic_inc(&orig->usage); >>> + return orig; >>> +} >>> ... >>> +void copy_seccomp(struct seccomp *child, const struct seccomp *parent) >>> +{ >>> + /* Other fields are handled by dup_task_struct. */ >>> + child->filter = get_seccomp_filter(parent->filter); >>> +} >> >> This is purely cosmetic, but imho looks a bit confusing. >> >> We do not copy seccomp->mode and this is correct, it was already copied >> implicitely. So why do we copy ->filter? This is not "symmetrical", afaics >> you can simply do >> >> void copy_seccomp(struct seccomp *child) >> { >> if (child->filter) >> atomic_inc(child->filter->usage); >> >> But once again, this is cosmetic, feel free to ignore. > > Right now get_seccomp_filter does the NULL check, so really this could > be reduced to adding an external get_seccomp_filter(p->seccomp.filter) > in place of copy_seccomp(). > > As to removing the extra arg, that should be fine since the parent > can't drop its refcount when copy_seccomp is called. At the very > least, I can make that change so it reads more cleanly. I had various conflicting thoughts while looking over the refcounting: - get_seccomp_filter is defined static, and has a single caller: copy_seccomp() - put isn't static, and has a single caller: kernel/fork.c:free_task() - having only get_/put_ touch ->usage seems cleaner to me - seccomp_attach_filter touches ->usage without get_seccomp_filter - having the initializing routine use atomic_set(..., 1) is a common pattern In a fit of extreme bike-shedding, I can't decide which is more sensible: - rename put_seccomp_filter to free_seccomp_filter and inline the get_seccomp_filter logic into copy_seccomp(). or - create a wrapper for put_seccomp_filter named free_seccomp_filter so that get_/put_ can both be static. -Kees -- Kees Cook ChromeOS Security
Powered by blists - more mailing lists
Confused about mailing lists and their use? Read about mailing lists on Wikipedia and check out these guidelines on proper formatting of your messages.